Filme werden nicht richtig indexiert!

Obwohl die NFO-Datei alle Informationen enthält wird die Videodatei nicht in die KODI-Bibliothek aufgenommen oder nicht alle Informationen übernommen. In anderen Fällen werden Umlaute nicht angezeigt.

KODI: Cover wird nicht angezeigt

Im letzten Kodi bzw. LibreElec Beitrag habe ich einen eigenen User für meine vielen Dokufilme und Dokuserien angelegt. Diese werden nun nicht mehr zwischen allen normalen Filme angezeigt. So wird es übersichtlicher. Leider gibt es nun wieder Probleme, dass mir einige Videos komplett fehlen, Umlaute in den Beschreibungen nicht angezeigt werden oder die Cover-Bilder fehlen. Nicht schön, somit Zeit die Fehler nochmals zu beheben. Diesmal aber richtig.

Bei Filmen/Serien werden Umlaute nicht angezeigt

Das liegt eindeutig daran, dass die Datei nicht in UTF-8 formatiert ist. Mach die Text-Datei auf und schau in deinem Texteditor (ich verwende TextWrangler am Mac und Notepad++ bei Windows) ob du die Formatierung auf UTF-8 ändern kannst.
Ist dies geschehen, bessere eventuelle Zeichenfehler aus und aktualisiere den Bibliothekseintrag.

KODI liest Filminfos nicht ein

Das Bild ist da, aber keine Infos um was es in dem Film geht. Das bedeutet dass wahrscheinlich kein Text in der „Plot“ Zeile der NFO-Datei steht oder der Eintrag erst gar nicht vorhanden ist. In meinem Fall war dies so. Sollte das bei dir auch so sein, speichere den Text in der Zeile ab und aktualisiere dann deine Filminfos.

Was tun, wenn das Coverfoto fehlt

Zur Kontrolle ob die NFO einer nicht erkannten Doku richtig eingelesen wird und es eventuell am Bild liegt kannst du die NFO-Datei am Computer öffnen, das Jahr eintragen oder ändern und die Filminfos dann mit der Fernsteuerung oder der Maus am Kodi aktualisieren. Haben sich die Einträge geändert, muss der Fehler am Eintrag der Coverdatei liegen (Pfad, Name falsch) oder die Datei kann nicht eingelesen werden. An den Abmessungen (1748x2480px) kann es bei mir nicht liegen da andere Bilder anderer Filme angezeigt werden.

Um zu schauen was Kodi wirklich einliest habe ich das Webinterface von Kodi geöffnet (http://x.x.x.x:8080), den Film geöffnet und dort den Pfad zum Poster kontrolliert. Es stand irgendwas zusätzlich zum Pfad in der Zeile. Ich habe den Inhalt entfernt und gespeichert.
Daraufhin den Pfad vom Thumb aus der NFO entfernt, abgespeichert und am TV neu eingelesen. Danach den Pfad wieder in die NFO eingetragen, abgespeichert und wieder neu eingelesen. Endlich, das Coverfoto wird angezeigt. Ab zum nächsten nicht erkannten Film bzw. Zur nächsten Doku.

Der Pfad in der NFO zum Poster passt. Der Pfad im Webinterface ist aber leer. Keine URL hinterlegt. Da ich doch viel in der Datenbank herumgespielt habe, bereinigte ich dieses über das Menü. Löschte den Film aus der Bibliothek und indexierte neu. Der zweite fehlerhafte Eintrag korrigiert.